Re: ACTION REQUIRED: JSR-375 Expert Group


Arjan Tijms
 


On Thu, Aug 3, 2017 at 12:14 PM, Werner Keil <werner.keil@...> wrote:
In 2.5 of the Spec, was referring to CDI 1.2, not 2.0 (which is included in Java EE 8 and Final by now) on page 22 deliberate?

The dependencies are also Java EE 7, so as the minimum version for CDI it sounds OK.

Indeed. I think this came up during one of the calls or perhaps on the list (can't quite remember) as well. We would have loved to take advantage of some of the CDI 2.0 features, but in the end it didn't happen. So everything is exclusively based on Java EE 7 APIs, perhaps unfortunately, but the upside is that the RI can be used on existing EE 7 servers as well.

Kind regards,
Arjan


 


Join javaee-security-spec@javaee.groups.io to automatically receive all group messages.