ServletMapping should be HttpServletMapping
AT> Name change should be okay indeed.On Tue, 2 May 2017 19:47:43 +0200, arjan tijms <arjan.tijms@...> said:
AT> On Tue, May 2, 2017 at 7:43 PM, Mark Thomas <markt@...> wrote:
On 01/05/17 08:40, Greg Wilkins wrote:
GW> I know I've promised feedback on this API from an implementation many
GW> times... and now it is probably too late... however....
GW> Shouldn't this class be called HttpServletMapping? It is in
GW> javax.servlet.http and all other Servlet related classes in that package
GW> are prefixed with HttpServlet. I know it is a small thing, but the
GW> first hurdle I have in implementing this is dealing with the
GW> inconsistent naming.
MT> No objections to the name change.
I have opened <https://github.com/javaee/servlet-spec/issues/176> for
this. The API changes are at
The implementation changes are being tracked at
Note that in addition to changing the name of the class, I also changed
the name of the method from getServletMapping() to
I trust that no-one will disagree with this, but if you do, please let
| edward.burns@... | office: +1 407 458 0017